Jump to content
  • Sky
  • Mint
  • Azure
  • Indigo
  • Blueberry
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Pomegranate
  • Ruby Red
  • Orange
  • Banana
  • Apple
  • Emerald
  • Teal
  • Chocolate
  • Slate
  • Midnight
  • Maastricht
  • Charcoal
  • Matte Black
  • 0
MrunalS

Help/Support Theos asks for endless dependencies

10 posts in this topic

Question

I needed UIKit framework which I imported in makefile after which I downloaded the UIKit framework from Xcode's iPhone sim. Now Theos is asking me for foundation header. And if I try to remove the import statement it gives more errors. How do I solve this?

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1
Just now, MrunalS said:

I think, github is not working on iOS now because of ssh weak encryption algorithms being removed... I'm getting an error...

fatal: unable to access 'https://github.com/theos/theos.git/': error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

That's correct. You will need to clone theos on your Mac first then rsync it to your iDevice as there's no way to clone it straight to your iDevice unless the issue is fixed.

I had the same error as you, search that and you will find the solution and the rsync command. :)

Share this post


Link to post
Share on other sites
  • 0

You need to install theos properly with all the headers.

See this tutorial: 

 

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, DiDA said:

You need to install theos properly with all the headers.

See this tutorial: 

 

Thanks a lot! I'll take a look right now.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, DiDA said:

You need to install theos properly with all the headers.

See this tutorial: 

 

I think, github is not working on iOS now because of ssh weak encryption algorithms being removed... I'm getting an error...

fatal: unable to access 'https://github.com/theos/theos.git/': error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, DiDA said:

That's correct. You will need to clone theos on your Mac first then rsync it to your iDevice as there's no way to clone it straight to your iDevice unless the issue is fixed.

I had the same error as you, search that and you will find the solution and the rsync command. :)

I did the rsync with recursive, time options... Now I tried to 'make package' again I got a different error this time...

>Making all for tweak ...

linking tweak ... (armv7)

Ld: file not found /usr/lib/system/liblaunch.dylib for architecture armv7

clang-5.0: error: linker command failed with exit code 1

I am using Stashing for iOS 9.2-9.3.5, is this the reason for the error?

Share this post


Link to post
Share on other sites
  • 0

Are you sure you're just cloning it? Do you have dependencies installed?

Share this post


Link to post
Share on other sites
  • 0
28 minutes ago, DiDA said:

Are you sure you're just cloning it? Do you have dependencies installed?

Yeah, I did the cloning and yes I have the dependencies installed.

When I executed this: 

apt-get install -y --force-yes org.theos.dependencies org.coolstar.iostoolchain git unzip ldid

It said 0 removed, 0 upgrade etc. So I'm sure that the dependencies are there. I don't what that error is about... How can symlinks be missing from that directory?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Aush0k
      I never put shoes on, but even with disabling the mod my defense is still 2147m. Any fix?
    • By MEMOTNTN
      Hacks used to work find until I did this:
      now when I start a game nothing pop up. Any help please?
    • By Taylor Meyer
      couldnt think of a better title because im so pissed off 
      so i found 2 features for this game and Unlimited crystals and credits well they work perfectly fine i found ammo but couldnt test it because of the stupid dump B*** S*** problem whats happening is in my Tweak.xm i add the offsets and the stuff required so like this to where it says 
      ************************/
      //add features here!
      addHack(@"Unlimited Credits ", @"Sets credits to a huge amount", font, {0x123456789}, {0x12345678}, {0x12345678});
      addHack(@"Unlimited crystals ", @"Sets crystals to a huge amount", font, {0x123456789}, {0x12345678}, {0x12345678}); 
      addHack(@"Unlimited Ammo ", @"Sets ammo to huge amount", font, {0x123456789}, {0x12345678}, {0x12345678});
      -------------------------------------------------------------------------------------------------------------------------------------------------------------------------
       
      so i add and remove other deb and compile and i install new deb and the  Unlimited Ammo feature doesn't appear in the mod menu so i change the features around so like this 
      addHack(@"Unlimited Ammo ", @"Sets ammo to huge amount", font, {0x123456789}, {0x12345678}, {0x12345678});
      addHack(@"Unlimited Credits ", @"Sets credits to a huge amount", font, {0x123456789}, {0x12345678}, {0x12345678});
      addHack(@"Unlimited crystals ", @"Sets crystals to a huge amount", font, {0x123456789}, {0x12345678}, {0x12345678}); 
       
      and i compile again and removed the other DEB and install new one well in the new DEB it just shows this in the mod menu  
       
      addHack(@"Unlimited Credits ", @"Sets credits to a huge amount", font, {0x123456789}, {0x12345678}, {0x12345678});
      addHack(@"Unlimited crystals ", @"Sets crystals to a huge amount", font, {0x123456789}, {0x12345678}, {0x12345678}); 
       
      @RudePerson
      @Joka
      or anyone else
       
       
       
    • By ArSoz
      my cydia is broken and each time I access it the first time it crashes and the second time it opens and the blackscreen pops up and it says that batterypercentx can’t be installed because it can’t find an archive for it and when I press return to cydia none of my tweaks show up none of my sources work and I can’t download anything any help would be appreciated I have ss if you need them thanks
    • By Harkinssr9
      hi guys sorry if this has been answered before or im in the wrong place (remove if not allowed)
      im having trouble when trying to install .deb files using filza when i click on install i get command not found, i have tried the command su root but then it askes me for a password and i have no idea what this could be (could this be down to using a free version of the app)
      i have also tried to convert the file to an .ipa using Xcode but it always fails to sign off the app 
      ive kinda hit a brick wall with this one any help would be much appreciated 
      thanks in advance you guys rock 
      Quick update I have found that the password is alpine 
      now It runs through the process and when I respring there’s no file installed 
  • Recently Browsing   0 members

    No registered users viewing this page.


    • Administrator |
    • Global Moderator  |
    • Moderator  |
    • ViP Plus |
    • ViP |
    • Cheater  |
    • Modder  |
    • Novice Cheater |
    • Rookie Modder |
    • Contributor |
    • Senior Member |
    • Member |
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.