Jump to content
  • Sky
  • Mint
  • Azure
  • Indigo
  • Blueberry
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Pomegranate
  • Ruby Red
  • Orange
  • Banana
  • Apple
  • Emerald
  • Teal
  • Chocolate
  • Slate
  • Midnight
  • Maastricht
  • Charcoal
  • Matte Black

Birdie Arrived

Member
  • Content Count

    36
  • Joined

  • Last visited

Community Reputation

5 Beginner

About Birdie Arrived

  • Rank
    Learning the Ropes

Profile Information

  • iDevice
    iPhone 7
  • iOS Version
    12.2
  • Jailbroken
    No
  • Android Device
    Tab S
  • Android Version
    8.0
  • Rooted
    No

Recent Profile Visitors

361 profile views
  1. I have similar feeling. (I have no technical issue on using Cydia Impactor) However, if using Cydia, it's not only inconvenient to use a computer, but it can only be used on 3 apps. The worst is that this re-impact work has to be repeated every 7 days. It's really frustrated if there is no easy installation of ios hacks.
  2. @DanYal I have installed the Jap version of DBL from isogod app. Today when I opened the game, there was a 7mb data download. After that I can't auto-Complete challenges or not even has Unlimited Ki in any battles with this hack. Hope that Bandai has not patched the game. Please take a look of it thanks.
  3. Thanks for the great work @Zahir This update works well. Global boss battles can also be completed successfully without crashing 😃
  4. @Zahir To further clarify, a new version (1.61.1) of the game has just been released, so pls dl the correct version from the app store. Thanks
  5. @Zahir Please kindly update the hack, URL of official app Fyi, the one-hit kill did not work in the last hack version. pls kindly take a look. Thanks. 😊
  6. I know you're working hard, but please make this game work. Injustice 2 is still crashing.
  7. @Zahir Looking forward to the update version 1.5.1 <App Store link>. 🙇‍♀️ Though I have requested an easy installation. This time, please consider to provide the reimpact file too, since as many users, i have the iOS incompatible issue @DiDA
  8. Thanks. Sadly, 🥺My iOS is 12.1.4. May I ask how can I downgrade the os?! Any easy way could be suggested please
  • Recently Browsing   0 members

    No registered users viewing this page.


    • Administrator |
    • Special Rank |
    • ViP Pro |
    • ViP Jailed |
    • ViP |
    • Cheater  |
    • Modder  |
    • Novice Cheater |
    • Rookie Modder |
    • Contributor |
    • Senior Member |
    • Member |
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy - Guidelines